Q. What are the Hardware/Software requirements?

Screen_Shot_2019-10-30_at_4.05.47_PM.png

A. Audit Assistant will run on any hardware capable of running modern browsers. We test in Safari, Chrome, Firefox and Internet Explorer. Older versions of Internet Explorer are not recommended as many features will either not work at all or not display properly (drag and drop of attachments for example) - we recommend if possible Chrome, Firefox or Safari. Will also work on tablet and smartphone.

 

 

Have more questions? Submit a request

Subscribe to our mailing list

We have a regular newsletter which includes the latest updates in the audit and assurance space as well as on to our latest work.

Click here to view previous newsletters, enter your email bellow to subscribe.